OpenRoads Designer CONNECT Edition SDK Help

CreateTangentToTwoLinesThruPoint Method

Creates Tangent Line when given Spiral, Thrupoint, and Radius

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public static  CircularArc[]CreateTangentToTwoLinesThruPoint( Line line1, Line line2, DPoint3d thruPoint,double tolerance)

Parameters

SettingDescription
  Line First line used as reference
  Line Second line used as reference
  DPoint3d Thru point of the arc
   tolerance of the mathematics

Return Value

CircularArc[]

See Also